Author Topic: GPG 2.2 passphrase  (Read 466 times)

Marcel

  • Newbie
  • *
  • Posts: 1
    • View Profile
GPG 2.2 passphrase
« on: August 15, 2018, 08:05:05 am »
Feeling silly. Installed CM on Kubuntu 18.04; GPG version 2.2.4.

During Easy Setup, CM does not ask for a password. In another thread, Mike wrote:
The password field is supposed to be grayed out. Proceed with the key setup.
GPG 2.1 handles its own keys and therefore does not use the password field.
so I went ahead. But if I then click [New Msg], I get the popup saying "Please enter the passphrase to unlock the OpenPGP secret key" which I obviously don't have.

If I then leave that password field empty and hit OK, there are no error messages but also no message composition window.

I tried both confidantmail_0.44-1.deb and confidantmail_0.44-2.deb with the same results.

I'm clueless (as well as incompetent... :-[). Any help is much appreciated.

Mike

  • Administrator
  • Full Member
  • *****
  • Posts: 109
    • View Profile
Re: GPG 2.2 passphrase
« Reply #1 on: September 03, 2018, 11:03:09 pm »
Did it ask you to create a passphrase (GPG popup) when you created the key?
The thing about GPG 2.x is it does not let me do anything with the passphrase. It pops up and asks whenever it feels like it, and returns an error when it doesn't get a passphrase.